Back to overview
Resolved
System Bug Affecting the Request Callback Feature in Service Detail Dashboards
Aug 21, 2026 at 5:44pm UTC
Affected services
Acme Revival Platform
Resolved
Aug 24, 2026 at 5:47pm UTC
The issue has been resolved. Users on affected web browsers can now successfully submit their phone number through the callback request modal.
Affected services
Created
Aug 21, 2026 at 5:44pm UTC
A bug was identified that prevented some users on certain web browsers from submitting their phone number through the callback request modal.
Affected services