Back to overview
Degraded
Inbound Help Desk Email Bouncing
Apr 17 at 09:00am MDT
Affected services
Acme Revival Help Desk
Resolved
Apr 17 at 02:09pm MDT
This has been resolved.
Affected services
Created
Apr 17 at 09:00am MDT
On Monday, April 17th from approximately 9:00am - 2:00pm (MDT) some emails may have bounded back to the sender from help@acmerevival.com. We've corrected the issue and all systems are back to normal.
Affected services