Back to overview
Degraded
Outbound Email Notifications Not Delivering
Apr 26 at 12:40pm MDT
Affected services
Acme Revival Platform
Acme Revival Help Desk
Resolved
Apr 27 at 10:43am MDT
All outbound email notifications are firing at this time. This has been resolved.
Affected services
Updated
Apr 26 at 03:52pm MDT
Most notifications are firing at this time. Repair / Service updates are not sending email notifications at this time. We are still working on this issue.
Affected services
Created
Apr 26 at 12:40pm MDT
We are currently investigating an issue with outbound email not firing or delivering to users. This may effect your ability to submit support requests, and receive order notifications.
Affected services